Infiniti QX60 Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi all, my 2013 JX35 is developing some rust where the hydraulic power lift sits. Anyone else experiencing this problem? A friend of mine has a 2015 QX60 and it completely snapped off for him.

6112


This one is the 2015 QX60

6113
 

·
Registered
Joined
·
601 Posts
whoooo.. that's some serious gunk and looks bad. Mine isn't nearly that bad, look clean and generally dusty. Do you live in the snow-belt?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
whoooo.. that's some serious gunk and looks bad. Mine isn't nearly that bad, look clean and generally dusty. Do you live in the snow-belt?
Indeed! We are both in the Greater Toronto Area up in Ontario, Canada. My vehicle is normally in the garage over the winter time. Didn't realize how gunky and dirty it was until I paid attention. Wondering if I should just wash it off with soap and water and it will be ok?
 

·
Registered
Joined
·
601 Posts
My JX is also garage based, but Texas doesn't experience snow/salt like you do in Ontario. Sounds like the water/dirt/salt is getting splashed up near the struts causing the eventual rust, and the back struts likely aren't covered with salt-protection like the undercarriage. that sucks.. Going forward I recommend hosing out the back every week when they start salting the roads.

Unfortunately Infinit covers rust for 7 years so this won't be covered.
 

·
Registered
Joined
·
1 Posts
Part is $504 each, both sides are rusted pretty good but only one of them snapped. At that price I'm going to just replace the one and hope for the best.
 
1 - 5 of 5 Posts
Top