Infiniti QX60 Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I’m hoping someone can help me. I have a 2014 QX60 that the bearings on the radiator fan started going out a few months after I got into an accident and had to have it replaced. That was 4 years ago and no problems after that until 6 months ago when the car started overheating if I sat in a parking lot with the car on for longer than 5 mins. My husband figured the radiator fan had just died because neither one was running so he replaced it. Worked great for a week then same thing happened again. So now he’s changed the thermostat sensor(I think that’s what it’s called), we’ve gone through 5 radiator fans and he changed out the computer? Nothing will fix this permanently. Everything we’ve done fixes it for a week or so then it happens again. Of course it isn’t under warranty anymore but we also took it to a mechanic and he can’t figure it out either. I’m so sick of this if I didn’t owe more on the car than it’s worth I would get rid of it! Help!!!
 

·
Registered
Joined
·
643 Posts
Wow, that's a lot of repairs. Sorry to hear. I hope you're able to find a mechanic that can narrow down the specific problem and get this behind you.
 

·
Registered
Joined
·
20 Posts
Yea, 5 radiator fans tells me something else is wrong. Is there a radiator fan control module on the QX60? I know some of the Infinite's have one. Just throwing it out there because I'm not sure. If the QX60 has one it's worth looking at.
 

·
Registered
Joined
·
463 Posts
I’m hoping someone can help me. I have a 2014 QX60 that the bearings on the radiator fan started going out a few months after I got into an accident and had to have it replaced. That was 4 years ago and no problems after that until 6 months ago when the car started overheating if I sat in a parking lot with the car on for longer than 5 mins. My husband figured the radiator fan had just died because neither one was running so he replaced it. Worked great for a week then same thing happened again. So now he’s changed the thermostat sensor(I think that’s what it’s called), we’ve gone through 5 radiator fans and he changed out the computer? Nothing will fix this permanently. Everything we’ve done fixes it for a week or so then it happens again. Of course it isn’t under warranty anymore but we also took it to a mechanic and he can’t figure it out either. I’m so sick of this if I didn’t owe more on the car than it’s worth I would get rid of it! Help!!!
Time to take it to the dealer and let them find the problem.
 

·
Registered
Joined
·
100 Posts
I had a similar problem the dealer fix is to replace the fan shroud as well as the fan, has your husband done that? The shroud gets warped and mostly causes the noise
 

·
Registered
Joined
·
4 Posts
I can assume that somewhere in the wiring problem. Or somewhere bare wire and you need to insulate it and it just closes about metal.
 

·
Registered
Joined
·
10 Posts
This happened to my 2015 qx60 and it took 3 or 4 fan replacements and it finally took. My mechanic said that the fan has a very unique speed control mechanism and he thinks that's what kills the new fans, even being OEM parts, they can't handle it?? Who knows but every time he replaced the new fan under warranty so I really only bought 1 fan.
 
1 - 7 of 7 Posts
Top