Infiniti QX60 Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
I have a few questions to my fellow QX60 owners. I have put about 1300 miles on the car and indeed it is very nice but I would like to hear your experience on the following:

1) I have noticed that when you put the car in Park, I feel the car has some leeway motion before it completely stops; not that much but there is some. It is not like it is still on Drive but you feel as if the body of the car is floating on water. I would be worried if I am in my tight garage or in very close proximity to other vehicles. I have never had that on any of my cars. Is this normal for QX60?

2) I was going up a steep road and had to stop for a red light. I noticed the car go backward when I took my foot off the brake pedal and had to press it again quickly. I know this is normal for really steep roads but on this one it was not that bad. I was not sure if this is just my car or it is all the QX60's?

3) Ok, this may sound weird but the texture of the rubber/leather dashboard material on top of speedometer, tachometer...etc. is rough. I mean you can feel tiny dots as if the surface needs sanding. It is a minor issue but I feel it is a quality control problem. Is this something that can be sanded or replaced?

4) The HDD navigation system has once restarted itself about 20-30 sec after starting the car. I am not sure if I should worry about that?

I had a bad headrest on arrival (i.e. the DVD monitor is stuck in one position). A replacement has been ordered and should be installed soon. Also, one of the doors was squeaking and I had to grease it using white lithium.

Thank you all for your feedback.
 

·
Premium Member
Joined
·
563 Posts
The only thing I can address is the navigation restarting. My unit went haywire on a long trip back east. It kept restarting (about 10 times before settling down). I took it to the dealership and they had a firmware update to correct the problem. It is a rare situation and I've never had the problem again since the firmware update. There is a technical service bulletin out on the issue.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
Thank you. I am going to the dealership to install the headrest next week and will bring this up.
 

·
Registered
Joined
·
225 Posts
1) not sure what cars you've had that didn't roll after putting them in park and releasing the brake, but the qx60 is better than most of my recent large vehicles (escalade was the worst, but also Toyota minivans and Lexus vehicles... I think my older BMW was pretty good, but even when they "roll" that stress not moving as much as you think! I never hit anything and I had less than three inches, front and back, when I parked my escalade in my garage).

2) the qx60 needs alt a 5.7 degree slope before it will hold. That's steeper than you probably think. I also thought this was a problem, but it will refuse to hold you on less steep hills. Not sure why they designed it this way, but they did.

3) have your compared yours to others on the lot? It's not smooth, but it's not rough, either. I would definitely not sand it, though! If it seems different than others on the lot, you may have something that should be replaced.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
1) not sure what cars you've had that didn't roll after putting them in park and releasing the brake, but the qx60 is better than most of my recent large vehicles (escalade was the worst, but also Toyota minivans and Lexus vehicles... I think my older BMW was pretty good, but even when they "roll" that stress not moving as much as you think! I never hit anything and I had less than three inches, front and back, when I parked my escalade in my garage).

2) the qx60 needs alt a 5.7 degree slope before it will hold. That's steeper than you probably think. I also thought this was a problem, but it will refuse to hold you on less steep hills. Not sure why they designed it this way, but they did.

3) have your compared yours to others on the lot? It's not smooth, but it's not rough, either. I would definitely not sand it, though! If it seems different than others on the lot, you may have something that should be replaced.

Thank you.

1) QX60 is the largest I had so far so this may be the reason.
3) It is not noticeable. You cannot see it, it is just when you touch it. So I did not discover it until a week later. It is not a big deal to me but I feel it is a quality issue I did not expect Infiniti to have.
 

·
Registered
Joined
·
19 Posts
Discussion Starter #7
Not yet. I will update you all when I do.

Other than the obvious trying it on the road, any hints on how to test whether the car holds on sloped roads? I am asking if I can tell using the tachometer (RPMs) on idle or so.
 

·
Registered
Joined
·
225 Posts
I'd stop on a steep hill, take your foot off the brake and the car won't roll for a few seconds. Not many, though. That's the only way to know. I don't think the tach changes, but you will know by the "stick" if it's working, for sure. Find the steepest hill you can find (note most highway exit ramps, at least around me, are not step enough!)
 

·
Registered
Joined
·
19 Posts
Discussion Starter #9 (Edited)
1) Ok so I went to the dealership today and the service person told me they could not get to the HDD thing and since I need to come back for a different issue, they will do it then.

However, I noticed that the system has reset its color, clock...etc., so apparently someone has been trying to update it or something. I checked "INFO" and now the current

"Program Version" is X9U62015
"Map Version" is GEN4 5.1

Do you know if these are the latest?



2) They are planning on replacing part of the dashboard because the fact that the texture is very rough and may be substandard for getting cracks...etc. I am not sure how much work and disassembly is involved. I am concerned something else may get broken or not installed correctly (rattling...etc.). Any thoughts?
 

·
Registered
Joined
·
19 Posts
Discussion Starter #10
[UPDATE: I called Infiniti and these versions seem to be the latest; latest was in October 2013 according to them. So they may have just reset it.]
 

·
Registered
Joined
·
19 Posts
Discussion Starter #12 (Edited)
I believe the service person just reset it. The interesting thing is that some options have been reset and some have not:

Reset: Color theme, time, average speed limits, and others.

NO change: Home address, guidance volume, map view, and others.

On a different issue, I spoke to the service advisor about my concern with replacing that part of the dash cover (i.e. I do not really know what to call it but it is that rubber/leather covering the interior on top of the glove box, HDD, meters across the whole front of the car all the way to the bottom of the windshield.) and if it will cause other issues with how sealed the body is and its original factory fit, rattling...etc. Well, he was quite confident. I am still not sure if I should replace it though.
 

·
Registered
Joined
·
225 Posts
I would not worry too much about the dash. I've taken such things apart on several other vehicles and there are a lot of fasteners and clips to hold them in. Should be a fine fit when done, assuming they do it right. If there are any rattles, they didn't do it right and you can get it fixed.
 

·
Registered
Joined
·
323 Posts
I would not worry too much about the dash. I've taken such things apart on several other vehicles and there are a lot of fasteners and clips to hold them in. Should be a fine fit when done, assuming they do it right. If there are any rattles, they didn't do it right and you can get it fixed.
one of the downsides with that is it can be easy to break some of those clips, something i'd be concerned about.
 
1 - 14 of 14 Posts
Top