Infiniti QX60 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Good Morning, This may seem like a little thing but the MPG on my display (as of last night)is locked in at 99.9 (See attached) The reason I am worried that it is a larger issue is that two days after I bought the car last month, it broke down on the side of the road because the gas peddle was not moving the car. I suspected transmission issues but it was (supposedly) I plug that was not seated correctly at the factory and had worked itself out. Been fine for the last week. What concerns me is that JUST prior to that first issue, I was seeing all kinds of MPG strangeness. It would go to 2 and then up to 90 and then it finally died. Has anyone else encountered this odd MPG issue? I am sure I can reset it and fix it but I think we can all agree that is not the point as there must be something else going on. Software update needed maybe?


I reached out tot he dealer this AM but have to hear back yet. I am sure I will as they are pretty good but wanted to see if I was the only one.


Thanks,
Chris
 

Attachments

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
I've a 2014 and never experienced the issue you noted. Very strange as it looks like trip computer is stuck. Does the mileage display in your dash display the same reading - using the buttons on steering wheel to navigate to mileage readout.
Definitely a dealer visit to fix.


So here is what my dealer sent me: "it appears that you just filled up and reset the average fuel economy reading. Look like after filling you may be on the interstate. It will show a reading like this after the fuel sensor has move 12 inches up after refueling and the monitor has not calibrated to the new fuel level location. Could take up to 25 miles to get a more accurate reading. All is normal. "


I struggle with this because I didn't just fill up and the car has never been below 3/4 tank. I also mentioned that I sat idle for 5 minutes and watch the MPG drop 2 MPG while sitting there. He said don't' watch it that close and idling will make it drop. I think I am being played here.
 

·
Registered
Joined
·
38 Posts
That sounds like BS to me. I fill up, reset and get right on the freeway all the time and it's never JUMPED to 99mpg. In fact mine is usually 8-10mpg for the first 10-15 minutes before gradually increasing to 20-23mpg and settling there.
 

·
Registered
Joined
·
1 Posts
Good Morning, This may seem like a little thing but the MPG on my display (as of last night)is locked in at 99.9 (See attached) The reason I am worried that it is a larger issue is that two days after I bought the car last month, it broke down on the side of the road because the gas peddle was not moving the car. I suspected transmission issues but it was (supposedly) I plug that was not seated correctly at the factory and had worked itself out. Been fine for the last week. What concerns me is that JUST prior to that first issue, I was seeing all kinds of MPG strangeness. It would go to 2 and then up to 90 and then it finally died. Has anyone else encountered this odd MPG issue? I am sure I can reset it and fix it but I think we can all agree that is not the point as there must be something else going on. Software update needed maybe?

Did you figure it out im having the same issue bought a qx60 yesterday snd it says 99.9

I reached out tot he dealer this AM but have to hear back yet. I am sure I will as they are pretty good but wanted to see if I was the only one.


Thanks,
Chris
 

·
Registered
Joined
·
103 Posts
I’ll go out on a different track here, check your battery connections at the battery. I have had repairs done where the power was disconnected and the cable wasn’t tightened down. It would cause readouts resetting and lights flashing. If you can twist them they need to be tightened.
 
1 - 6 of 6 Posts
Top