Infiniti QX60 Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I took my 2016 QX60 in for its 90,000 mile service today and of course they recommended thousands of dollars of addition work. Ok, I expected that, so I just went ahead with the service including new battery, coolant flush and regular services. when I was leaving the parking lot of the dealer I noticed that my radio/entertainment system was not working. It worked fine for 6 years until today. I turned around and went back to the dealer. They took it back to the garage again, then came back and told me the Telematic system went out and it will cost me $2300 to replace it. I was beside myself. The dealer said there was nothing they would have done that would have caused this and insisted I would have to pay. I refused and expressed my considerable displeasure with the situation. I find it hard to believe that with all the work they did on my car that it had nothing to do with this problem. Eventually they agreed to make the repair at no cost to me but I had to leave my car overnight. (I live 30 minutes from the dealer btw). Even though I convinced them to fix the problem for free, I was left feeling very distrustful of this dealer. Has anyone had similar problems with the telematics in their QX60? Anyone else had suspicions that their dealer is fabricating problems to be fixed? Sorry for the rambling post, but I’m still shocked about what happened.
 

· Registered
Joined
·
75 Posts
There is always a risk of something failing whenever you lend the vehicle to a friend, or let someone drive it into the dealership or it gets stolen. When the vehicle is back in your hands, the tendancy is to be hyper vigilant for any differences to your last recollection. Not saying that the dealer is responsible, but it could just be a coincidence that the telematics chose this time to get weird.
 

· Registered
Joined
·
7 Posts
I took my 2016 QX60 in for its 90,000 mile service today and of course they recommended thousands of dollars of addition work. Ok, I expected that, so I just went ahead with the service including new battery, coolant flush and regular services. when I was leaving the parking lot of the dealer I noticed that my radio/entertainment system was not working. It worked fine for 6 years until today. I turned around and went back to the dealer. They took it back to the garage again, then came back and told me the Telematic system went out and it will cost me $2300 to replace it. I was beside myself. The dealer said there was nothing they would have done that would have caused this and insisted I would have to pay. I refused and expressed my considerable displeasure with the situation. I find it hard to believe that with all the work they did on my car that it had nothing to do with this problem. Eventually they agreed to make the repair at no cost to me but I had to leave my car overnight. (I live 30 minutes from the dealer btw). Even though I convinced them to fix the problem for free, I was left feeling very distrustful of this dealer. Has anyone had similar problems with the telematics in their QX60? Anyone else had suspicions that their dealer is fabricating problems to be fixed? Sorry for the rambling post, but I’m still shocked about what happened.

This is a bit unrelated but about 15 years ago, I helped a friend with his eMachine PC. Yea, they were junk, but I backed up all the data, reinstalled Windows on it, and then tested it a bunch of time. Everything worked just fine. When he came over to get it, we powered it up and it failed. So, stuff does happen.
 

· Registered
Joined
·
937 Posts
Still, there is an expectation that your vehicle works the same as when it's dropped off.

Unfortunately, some mechanics (not all) will accidentally break stuff and not fess up to their boss or owner. The dealership is first to blame you or not take responsibility.
 
1 - 4 of 4 Posts
Top