Infiniti QX60 Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hi - Here is my story. Will provide the short version. Purchased my 2017 QX60 in Aug. First few days of driving, screen just freezes. Had to turn car off/on to get it to unfreeze. Scheduled appt. with service. 1st trip to dealership --> they basically said I was the first person to report such an issue and that they have to report to tech line and wait for an answer. Somewhat unbelievable that 'I' was the first person to report this issue but ok. Anyway they told me if it happens again to hold down the on/off knob for a few seconds and it will fix the issue. That actually did work. Happened a few more times after that, took videos of them all (total 10 videos to date), scheduled service #2 . Left car at dealership for 5 days, they said they found an error code and that after a reset the error code was gone, so all fixed. Drove car off lot, screen locks up immediately (literally 500 feet from exit of dealership). Scheduled service #3 , different dealership this time, they had the car for 5 days, and basically, this is what their recommendation to me is. Tech and Service adviser both advised me to:
1. Do not pair the phone or use the USB to charge play audio for a week
2. After a week Pair it and use 12V to charge
3. Do not use the USB connection when playing music with Pandora (through phone)
4. Use only Apple (since I have an iPhone 7 with the latest ios version) approve cable, after market cables do not work

In the end I left the dealership, and started testing functionality that I thought the dealership should have had answers for.
In the end, after 3 trips to the dealership, I am no better off now than I was when I initially drove it off the lot. I find this somewhat comical.
But I will test and hopefully over the next couple of weeks will be able to provide some good test data for my friends at Infiniti, at which time I am sure I will be scheduling my 4th service appointment.
 

·
Registered
Joined
·
204 Posts
Sorry to hear about experience, I have had mine for about a year and so far haven?t experienced the issues you mentioned. Occasionally when reversing the screen takes an extra second to two show the picture but that?s about it.

In my 2011 Murano I used to have issues similar to yours but I figured out it was related to non Apple branded cable. Once I swapped it out with original iPhone cable it was fine. Can?t say if it is the same in your case but give it a try.
 

·
Premium Member
Joined
·
539 Posts
Keep after them. I totally get the frustration of dealing with problems like this. But eventually Infiniti will step up and either replace the whole computer system, or replace your car if that's really the problem.

Not suggesting my techs would have told you anything different, but if you're in the Bay Area, I'll be happy to schedule an appointment for you and get you a loaner while we try to work our magic.

And finally, try this if you haven't already: reboot the InTouch system. To do this, press and hold the volume button for about 10 seconds (let go when the main screen blanks out). I know it sounds like every off-shore tech support solution, but it sometimes works wonders.
 

·
Registered
Joined
·
33 Posts
Hey, TheProfessor, was this ever resolved? My 17 QX60 is doing the same and so far the dealer has had it for several days and has not been able to reproduce the problem to isolate the defect.

On mine, the screen might freeze and when it does all nav/infotainment buttons, including steering wheel AV controls and power button, fail to work. If listening to radio & tapping a preset it changes to a different preset screen before freezing. The power button for a few seconds resets it so it functions again but obviously this is not a fix.

Service department so far has confirmed the related modules are not integrated with OBD so no codes are sent to the scan port. Also there apparently is no internal logging so there's no event data they can pull to help isolate. I had an earlier lockup when I happened to be in the dealer's neighborhood so they have seen it in action but weren't able to isolate it then.

I also had a defective FEB front camera module that's been replaced but that's unrelated.
 

·
Registered
Joined
·
3 Posts
Same Issue - BRAND NEW 2018 QX60

I am having the same issue. I just took delivery of my BRAND NEW QX60 3 days ago and it happened the same day. Turn the car on, press the touch screen, FREEZE. It happens about 70% of the time. The Infiniti guy on the phone told me "it's a big computer." LOL. They are coming to pick it up tomorrow. I have a feeling I have a big fight ahead of me...
 

·
Registered
Joined
·
3 Posts
So they came and picked up my brand new car on Tuesday. On Thursday they calledme and told me they could not reproduce the problem and they reloaded the software so they were bringing me back the car. I told them that isn't going to fix it and that it is a hardware problem with the bluetooth module (I have worked in tech for years. Not cars, but it is all the same). He added his phone and the whole system locked up competely. Today they replaced the "module." I don't know if this means just the bluetooth module or the whole system. They brought iback a few hours ago and I have not been able to reproduce the problem. I am cautiously optimistic, but I am not instilled with confidence with their brand or their service. It seems I know more than they do...
 

·
Registered
Joined
·
140 Posts
Don’t worry it must just be a “glitch”. :) Just kidding, really sounds like a hardware problem to me. Whatever module they replaced, let us know for other victims. Dealers will spend all kinds of their and your time on all kinds of cheap solutions and will only replace parts when you squeak like a rusty axle.
 

·
Registered
Joined
·
33 Posts
Probably the DCU (Dashboard Control Unit). That's what my service adviser keeps referring to.

In my case we're still troubleshooting and I'm presently advised to avoid using a USB drive & monitor to see if the problem recurs. Which, long term, is not acceptable as my music preference is to use a thumb drive.
 

·
Registered
Joined
·
1 Posts
Does anyone have any updates on what the issue is with the screen? The screen in my QX60 has frozen or gone completely black while driving three times. It has been at the dealership twice for this issue. They don’t seem to have a solution and said there is a case open with Infiniti engineers. I’m kind of at my wits end...
 

·
Registered
Joined
·
45 Posts
I had several issues with the screen and button controls occasionally glitching out (goes off, camera frames with no video, "snow", ...) on a new 2017. Dealer replaced the whole screen unit and have not had any issues since.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #13 ·
Sorry for getting back so late with an answer for some. Yes - for me it was the DCU that was defective. They replaced it after 3 or 4 visits. Thanks -
 
1 - 13 of 13 Posts
Top