Infiniti QX60 Forum banner
1 - 20 of 23 Posts

·
Registered
Joined
·
204 Posts
Discussion Starter · #1 ·
So, as you can read from my the pricing thread that I pulled the trigger on 2017 QX60 with Deluxe Tech Package and all the goodies comes with that. I bought it from a dealer 60+ miles from home which was great as i get to spend some time behind the wheel, and suddenly, my least desired option became my most admired one. If you recall, the only reason for me to get Deluxe Tech was to get panoramic moonroof, i didnt care much for the "electronic nannies". While no doubt Panoramic moonroof is must have even in the base model, the true beauty of this vehicle is in all the electronic aids you get. On my route back from the dealership I hit the typical NJ-NY traffic crossing infamous George Washington Bridge and Cross Cross Expwy, if you are from the area you know how bad it could be on Friday evening and if you are not from this area, consider you won a $100,000 lottery by not wasting precious time of your life sitting behind other cars staring nothing but brake lights in front of you for hours easily. So while I was having my dreaded drive, i enabled safety shield and saw how the QX60 started maintaining distance in front, within 5 mins. i was getting so used to with it :)

Though, I still hate the idea of self driving cars, I think they can be really helpful in stop and go traffic where you can let the computer do the work. At the end I am glad that $12,000 panoramic moonroof has some other uses as well.

Lastly, while I was enjoying my ride and appreciating everything the vehicle has to offer, FEB Malfunction warning popped up, and I got the FEB off icon in the dash. This happened as I was slowing down to the toll plaza and there was an unmarked Police car parked there, I am wondering if the cop had speed trap on and somehow that interfered with the radar that QX60 uses for safety shield. The malfunction light remained on till I stopped the car to pick up dinner. When i restarted it, the error was gone and everything started working again. I drove good 60-70 miles yesterday and played with safety shield but haven't encountered the issue again. So my theory is becoming firmer. Has anyone else experienced the same?

Sorry for a long winded post, I am glad that I went with QX60 over Pathfinder, it is definitely more classy and luxurious. Above all the Whole family loves it!
 

·
Registered
Joined
·
13 Posts
So, as you can read from my the pricing thread that I pulled the trigger on 2017 QX60 with Deluxe Tech Package and all the goodies comes with that. I bought it from a dealer 60+ miles from home which was great as i get to spend some time behind the wheel, and suddenly, my least desired option became my most admired one. If you recall, the only reason for me to get Deluxe Tech was to get panoramic moonroof, i didnt care much for the "electronic nannies". While no doubt Panoramic moonroof is must have even in the base model, the true beauty of this vehicle is in all the electronic aids you get. On my route back from the dealership I hit the typical NJ-NY traffic crossing infamous George Washington Bridge and Cross Cross Expwy, if you are from the area you know how bad it could be on Friday evening and if you are not from this area, consider you won a $100,000 lottery by not wasting precious time of your life sitting behind other cars staring nothing but brake lights in front of you for hours easily. So while I was having my dreaded drive, i enabled safety shield and saw how the QX60 started maintaining distance in front, within 5 mins. i was getting so used to with it :)

Though, I still hate the idea of self driving cars, I think they can be really helpful in stop and go traffic where you can let the computer do the work. At the end I am glad that $12,000 panoramic moonroof has some other uses as well.

Lastly, while I was enjoying my ride and appreciating everything the vehicle has to offer, FEB Malfunction warning popped up, and I got the FEB off icon in the dash. This happened as I was slowing down to the toll plaza and there was an unmarked Police car parked there, I am wondering if the cop had speed trap on and somehow that interfered with the radar that QX60 uses for safety shield. The malfunction light remained on till I stopped the car to pick up dinner. When i restarted it, the error was gone and everything started working again. I drove good 60-70 miles yesterday and played with safety shield but haven't encountered the issue again. So my theory is becoming firmer. Has anyone else experienced the same?

Sorry for a long winded post, I am glad that I went with QX60 over Pathfinder, it is definitely more classy and luxurious. Above all the Whole family loves it!
Congrats @coop64 on your new ride. For me the primary motivation to consider the deluxe tech package is the additional safety features that comes with it and they are not available in the drivers assistance package. I am happy to know that you find it useful. Please continue to post your experiences with the car. Happy Driving.
 

·
Registered
Joined
·
204 Posts
Discussion Starter · #3 ·
Thanks @maverickrobo. To be honest I was looking to get rear heated seats, and BCI in addition to the moonroof. However, just last week me and my family lucked out avoiding a very serious accident when the driver approaching from left ran through red light. Luckily our light had just turned green and it was bright sunny day. As I started to drive I saw this guy coming from left talking to another passenger in his vehicle and not paying attention to the road or he probably thought he still has the green light. I slammed my brakes my wife and kids screamed and miraculously he swerved around our minivan, he must have been doing 40+ MPH. While I was at no fault in this case, I am firm believer now that just being a good driver is not enough these days, you need to have the safety features to help you avoid accident not only from your own but other drivers mistakes as well. Hence, I didn't feel wasting money on Deluxe Tech and went ahead to purchase the vehicle with all safety features available.
 

·
Premium Member
Joined
·
570 Posts
Congratulations on your selection and I'm glad you posted your initial experiences with us. I think you would have regretted not loading the QX up and bet now that you have driven it for a short period of time, you wouldn't want it any other way.

As far as the warning light experience, it may have been a minor issue. I've found that when I've had a warning light come on unexpectedly they usually reset right away or after shutting down and re-starting.

Since I'm an original JX owner, I do appreciate the additional changes made for 2016 and now 2017. I like the fact that the car will pick up pedestrians now and is sensing further ahead. It comes in handy with the Christmas shopping in full swing and people not paying attention to where they are walking.

Enjoy your new car and please share your experiences.
 

·
Registered
Joined
·
204 Posts
Discussion Starter · #6 ·
......I like the fact that the car will pick up pedestrians now and is sensing further ahead. It comes in handy with the Christmas shopping in full swing and people not paying attention to where they are walking.

Enjoy your new car and please share your experiences.
I am wondering weather FEB and Pedestrian watch is working in my QX60 properly. I have checked the setting a couple of time to ensure that it is set to "On". However, I purposely delay braking when coming to a red light but the FEB does not warn, no warning, not braking either. Correct me if I am wrong FEB is on by default right? I don't have to activate it at each start by pressing button (safety shield) on the steering wheel?

I do notice car slowing down or even stopping when I press the safety shield button on the steering wheel.
 

·
Premium Member
Joined
·
570 Posts
You need to push the button on the steering wheel each time you start the car or the systems will be off except for the back up collision system which is on by default.
 

·
Registered
Joined
·
204 Posts
Discussion Starter · #8 · (Edited)
I think they changed it in 2017, check out this video, it doesn't say to hit the safety shield button on steering wheel.
 

·
Registered
Joined
·
204 Posts
Discussion Starter · #9 ·
Found answer to my first issue during initial drive: interference, this could be from both, the speed trap and/or high intensity light mounted on toll plaza blinding FEB camera.

From user manual:

SYSTEM TEMPORARILY UNAVAILABLE
Condition A:
In the following conditions, the FEB with pedes- trian detection system warning light blinks and the system will be turned off automatically.
● The radar sensor picks up interference from another radar source.
● The camera area of windshield is misted or frozen.
● Strong light is shining from the front.
● The cabin temperature is over approximately
104°F [40°C] in direct sunlight.
● The camera area of windshield glass is con- tinuously covered with dirt, etc.
Action to take
When the above conditions no longer exist, the FEB with pedestrian detection system will re- sume automatically.
 

·
Registered
Joined
·
204 Posts
Discussion Starter · #10 ·
I think they changed it in 2017, check out this video, it doesn't say to hit the safety shield button on steering wheel.
So I finally tested FEB/W this morning and it is working, and I didn't have to run over a pedestrian to test >:D after dropping my kids at school, I was rolling downhill and my foot was still on accelerator, gently pushing it as there were cars lined up in front, the traffic control guy had cars stopped in front of me, so while I was still rolling at safe distance and speed, FEB warns me as the distance between my car and car in front gets shorter.

By the way, the safety shield button wasn't pressed. FEB turns ON like BCI every time you start the car, unless you program it not to just like BCI.
 

·
Premium Member
Joined
·
570 Posts
I see they made this change for 2017. I like being able to set this on the Driver Assistance module. Makes more sense. Also I noticed the warning icons are very different and much more prominent. Thanks for sharing.
 

·
Registered
Joined
·
42 Posts
Coop64: Lastly, while I was enjoying my ride and appreciating everything the vehicle has to offer, FEB Malfunction warning popped up, and I got the FEB off icon in the dash. This happened as I was slowing down to the toll plaza and there was an unmarked Police car parked there, I am wondering if the cop had speed trap on and somehow that interfered with the radar that QX60 uses for safety shield. The malfunction light remained on till I stopped the car to pick up dinner. When i restarted it, the error was gone and everything started working again. I drove good 60-70 miles yesterday and played with safety shield but haven't encountered the issue again. So my theory is becoming firmer. Has anyone else experienced the same?

Yes, this has happened to me too. The yellow light flashed on the dashboard- when that "idiot" light [looks like a "W"] comes on and flashes, it disengages all LDW, LDP, FEB systems. It occurred twice in the morning at first startup. I brought it to my dealer. They said it was from a dirty radar sensor in the bumper.... It did happen again about a week later. If you hit the VDC button which disengages the electronic stability control [other car makers call it ESP], the same flashing "W" light comes on (not Flashing). That means that the same safety enhancements are OFF. Hit the VDC button on the lower dash again, and the "W" light goes off. Re-engaging all the safety systems. When the "W" light was flashing - hitting the VDC button had no effect. The flashing means there is a problem. I'll keep my eye on it, but if it's a dirty radar camera, that SUX.
 

·
Registered
Joined
·
204 Posts
Discussion Starter · #13 ·
... That means that the same safety enhancements are OFF. Hit the VDC button on the lower dash again, and the "W" light goes off. Re-engaging all the safety systems. When the "W" light was flashing - hitting the VDC button had no effect. The flashing means there is a problem. I'll keep my eye on it, but if it's a dirty radar camera, that SUX.
The FEB Pedestrian Watch camera is mounted on windshield behind rear view mirror so obstruction of its view can also cause FEB to malfunction. One cold morning my windshield was covered with ice. While I tried to clean the windshield with wipers and windshield liquid as much as possible the camera was still unable to "see" clearly and threw FEB failure message, and that "W" icon came On. After driving the vehicle for 5-7 minutes it warmed up and melted all the ice. The FEB failure light turned off automatically without requiring me to restart the vehicle.
 

·
Premium Member
Joined
·
570 Posts
I'm very happy with the 2016 model. Loved the 2013. Subtle differences and I don't regret trading it in other than I miss the Emerald Graphite color.
 

·
Registered
Joined
·
42 Posts
aller, I've posted elsewhere, that I was disappointed with my Infiniti dealer who failed to inform me that the 2017 QX60 was coming out just a few months after I took possession of the 2016 in June. I early traded my 2013 Infiniti M37X on a Come On early lease trade deal. If I was informed that the new 2017 would have certain enhancements, Especially the increased HP to 295 !! and more torque. I feel cheated by that because it the same lease deal on the 17 as the 16. That is a Bummer...

I did have some Buyers Remorse when I took this car. I took the QX60 right off the sales floor : Majestic White (pearl white) , Java Interior, Fully Loaded with all packages, 20" wheels, the Works... I'm a new grandparent (with one more grand child on the way), and really didn't need this large a vehicle [it doesn't fit in my garage], but I do love the room and comfort. The stereo (Bose) system with 15 speakers is a pleasure. The 17 has HD radio - that is lacking on the 16 - Bummer...
 

·
Registered
Joined
·
204 Posts
Discussion Starter · #17 ·
I didn't know that HD radio was introduced in 2017. This has been my first experience with HD Radio and it definitely makes the sound quality that much better. I usually listen to AM news stations and I remember double checking some of my usual stations to make sure that I am tuned to right station because their sounded so much better, similar or better than FM.
 

·
Registered
Joined
·
42 Posts
Coop64, That "W" light came on again after the recent snow here in NY area. The car was completely cleaned off. It came on after running it a mile or so. After re-starting it, it was gone. For those that do not know what that incurs: when that "W" yellow light flashes on the dashboard, it means that the FEB, LDW, and other pre-collision features are OFF. It may affect the ESC features too.

I'm going to bring it t the dealer again. The previous visit - they told me that a sensor was blocked or dirty? But there was no snow at that time. I think it is malfunctioning sensor. Oddly, although I did not drive in the snow day, the beeping and camera did not come on as it did in the other snow conditions.
 

·
Registered
Joined
·
204 Posts
Discussion Starter · #19 ·
It happened to me on Saturday night last week, it was clear night, car was clean, this was before the snow storm. Everything was back to normal after I restarted the vehicle. Since the error doesn't stay on permanently I think going to dealer will be useless, so I haven't done so, however, please let me know if they find faulty sensors.

I think the MOD (beeping camera) will come when driving in snow, I remember it was quite annoying and was impossible to turn it off, atleast while driving.
 

·
Registered
Joined
·
22 Posts
I recently purchased a fully loaded CPO Jx 35 and have been extremely happy except for the engine/ transmission noise durng hard acceleration. Not sure if you noticed any difference with the new model? Not sure if a cvt software update would made a difference? Any thoughts would be greatly appreciated!
 
1 - 20 of 23 Posts
Top