Infiniti QX60 Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
I have a 2017 QX60 with 88K miles and the dealer first reported that two of the fuel injectors was leaking and needed replacement but ended up replacing all six under the extended warranty I purchased when new. I’ve been using Costco premium gas almost exclusively and get regular service at recommended intervals. The engine light came back on after a few days and the misfire came back. The engine runs rough and I can’t use ECO mode as I have little power. This was the original problem. I drove the car for one week, 600 miles before returning it to the dealer for service. They are working on it now, talking about getting Infiniti involved for the diagnostics since they thought this was fixed.

Has anyone had any similar problem?
 

·
Registered
Joined
·
601 Posts
"talking about getting Infiniti involved"

Are you talking about Infiniti Consumer Affairs? They won't do anything as long as the dealership is trying to fix this. I hope they get another Tech to figure this out.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
"talking about getting Infiniti involved"

Are you talking about Infiniti Consumer Affairs? They won't do anything as long as the dealership is trying to fix this. I hope they get another Tech to figure this out.
The manufacturers have a Technical Support Department and will send out an engineer to help with the repairs. I used to work for a different manufacturer doing the same thing and these engineers are very good and have the entire engineering department behind them. I have my own ideas of how to repair the car that would completely resolve the problem, but they have to come to conclusion themselves to justify paying for it. (Replace the ignition coils and computer) The tech already reloaded the software that runs the car and replaced all of the fuel injectors and spark plugs.
 
1 - 3 of 3 Posts
Top