Infiniti QX60 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter · #1 ·
Hey all,

Just got my 15,000 mile service yesterday then this morning I get in my 2016 QX60 and start it up, press the brake to shift and hear this LOUD clicking sound. I depress brake a few more times and hear the click every time.

I'm leaving mid-week on a 4,000 mile cross country road trip. Any ideas how serious this is? I really don't have time to get service again. The nearest infiniti dealer is 3hrs drive away.
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #2 ·
Ok. I took it to the local Nissan dealer and they said this sound is "normal". I have NEVER heard my car make this annoying clicking sound before and I owned a G35 for the last 10 years and it did NOT make this sound.

Would anyone else be willing to chime in here and let me know if your QX60 makes a clicking sound when IN PARK and you depress the brake pedal!?

For a $55k+ car, it shouldn't be making these sorts of noises!
 

·
Registered
Joined
·
38 Posts
Discussion Starter · #5 ·
Thanks guys. I plan on going back to the dealer but it's a 6 hour round trip for me, so I wanted to get some feedback for I go in there and scream at them! :)

The Nissan dealer is the one that said it was normal, the Infiniti dealer was the one who said it needed to be fixed.

My 15k service was just oil, tire rotation and cabin filter. Nothing special.

I'll update next time I'm back at the infiniti dealer.
 
1 - 5 of 5 Posts
Top