Infiniti QX60 Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Just bought a brand new fully loaded 2017 QX60 with all the packages.

Brought it home a week ago, parked it on driveway. Next morning, noticed 2-3 small oil spots on my driveway.

The next day, noticed fresh oil spots. The spots always appear right under the engine.

Also, after driving car 100 miles, my MPG was 11 MPG :eek: I thought 2017 gave 19/22 MPG. So, I was super surprised.


Anyway, took the car yesterday to my local dealer for service - they replaced the Right Side VCT Solenoid, they said it was the cause of the leak.
Just picked up the car a few hours ago and I will check tomorrow to see if there's any new oil spots (hopefully none!)

Just curious...has this happened to other Qx60 owners ? Wondering if this is a known issue or just a faulty sensor from the factory.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Update:

I took my Qx60 into a local dealer , 5 days after I purchased it brand new.

The Dealer stated the there was a faulty VTC Solenoid. They replaced it and now, no more oil leak!


Haven't had an oil leak on my driveway since I was a teenager lol - certainly did not expect a brand new Infiniti to have this issue.
 

·
Registered
Joined
·
323 Posts
Glad to hear the issue got cleared up, lucky you don't live in a Condo since they typically charge you for oil clean ups.

Aside from that how has your QX60 been treating you so far? Being a vehicle as new as this is, it's one question that's always coming to mind, always bugs to be worked on vehicles in its first couple years of production.
 

·
Registered
Joined
·
42 Posts
Good Luck with your 2017 QX60..... I have a 2016 since June 2016. I wish I had known of the changes that would appear in the 2017. Especially the increased HP to 295 !!!! Anyway, regarding the MPGs, I am about 15% behind the posted 19/26 claimed. I have averaged (I have not reset the MPGs on the car trip computer since the beginning) with 6200 miles on the clock about 21.6 on the internal computer. Checking the Instant MPGs on the trip monitors when resetting the trip computer after a fill up (always use 93 Octane fuel), at 65 MPH on the highway - I'll see 25 MPGs with STD setting!!

I have not experimented by using the ECO setting in stop and go traffic situations. No way will you see 19 MPGS driving in local suburban driving.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Hi guys,

Me and the wifey love the new QX60 - we got it fully loaded with all the packages, so it's really cool to have all the gadgets.

The 295 HP is great and definitely noticeable from 2016 - we test drove '16 too. The cameras are higher resolution as well, which is nice. The car runs smoothly and things work well so far...but we only have 600 miles on the car...so let's see how things go..

I see the MPG hit 31 MPG on instant fuel economy monitor while driving about 65-75 on highway on STD mode....but obv it changes a lot due to ups/downs of the road.
overall, i'm at 21.7 MPG after 600 miles -- I only use 87/89 octane,(the cheapest unleaded gas available). Even on my BMW, I stopped putting 93 octane a couple years ago, just put it 93 once a month now...still get 30 MPG on regular on my 3 series on the high way.

Will post back here with any updates after I put a few K miles on the vehicle
 
1 - 6 of 6 Posts
Top