Infiniti QX60 Forum banner
41 - 48 of 48 Posts

·
Registered
Joined
·
3 Posts
Sorry to bump this thread, I have a similar issue. There is no airflow out of the floor vents. If I change the setting back to the dash it works. When you all were having this issue was it affecting all vents?
It was all front vents closing after a period of time. Only the rear seat vents continued to work. Sounds like a different issue and I think Bsante is right on the BCU - Good Luck!
 

·
Registered
Joined
·
2 Posts
I need Help!

I have a 2015 QX60
I have a 2 part issue

Part 1
My ac line contentious to freeze.... Its now cold and the heat is on.... this should not be happening.

Part 2
After driving the car for about 30 min the AC or Heat will not come out of the vents. The blower sounds like a jet engine by the glove box.

This issue has been going on for about a year now and I'm over it. I have taken this to a mechanic and they kept the car for a week and "Cant Replicate The Issue" Not sure what else to do. I don't have all the money in the world to take to multiple mechanics. I am Savvy when it comes to fixing things but not diagnostics.

Things that have been replaced
The AC lines have been blown out a few times.
New Compressor
New Blower Motor
New Cabin Air Filter
Do you use the remote start
We seem to have the same issue when we use the remote start if we manually start it we have heat
 

·
Registered
Joined
·
1 Posts
I have a 2017 QX60 with similar air not flowing issues. I'm getting nothing from vents or floor and what little leaks out is always hot. After trying various easy fixes, I took it to the dealer for a diagnostic. The technician said the issue is a bad ITS and Audio Switch, Part Number 28395-9NJ1A. They want over $1500 for just the part. Does that part sound right? I'm not having any audio issues so the title just seems off.
 

·
Registered
Joined
·
2 Posts
I need Help!

I have a 2015 QX60
I have a 2 part issue

Part 1
My ac line contentious to freeze.... Its now cold and the heat is on.... this should not be happening.

Part 2
After driving the car for about 30 min the AC or Heat will not come out of the vents. The blower sounds like a jet engine by the glove box.

This issue has been going on for about a year now and I'm over it. I have taken this to a mechanic and they kept the car for a week and "Cant Replicate The Issue" Not sure what else to do. I don't have all the money in the world to take to multiple mechanics. I am Savvy when it comes to fixing things but not diagnostics.

Things that have been replaced
The AC lines have been blown out a few times.
New Compressor
New Blower Motor
New Cabin Air Filter
The issue with ours was the rear ac was turned on in the control panel make sure they are both on heat or both on a.c
 

·
Registered
Joined
·
1 Posts
My dealer replaced the blower motor a few days ago but the issue came back. They could not replicate it at pickup but I was able to in about 10 minutes the next day. Took it back today after the air stopped blowing and it was...the cabin air filter. It was getting sucked up into the airway and they could even see it this time when I brought it in. I will be putting some miles on it the next few days to see if that is the case, since they just left it out.

Could be a cheap filter or the frame that holds it is cracked, either way this may be it. If the other drivers are still having issues, try taking your filter out (you can easily do it yourself) and drive it for a while and see if that fixes it.
So did this fix hold up and completely resolve your issue?
I am going to try this as ours just went out AGAIN 100 miles into a 280 mile drive today. Its 39 degrees outside and we have kids in the car. I told my wife, that's it - this [email protected]#ing 2015 QX60 is going in the trash and we are getting a new car. But I am hopeful this will fix it as I've never heard of this fix but have been to dealers and mechanics enough in the last 1.5 years with the same issue.
 

·
Registered
Joined
·
4 Posts
I need Help!

I have a 2015 QX60
I have a 2 part issue

Part 1
My ac line contentious to freeze.... Its now cold and the heat is on.... this should not be happening.

Part 2
After driving the car for about 30 min the AC or Heat will not come out of the vents. The blower sounds like a jet engine by the glove box.

This issue has been going on for about a year now and I'm over it. I have taken this to a mechanic and they kept the car for a week and "Cant Replicate The Issue" Not sure what else to do. I don't have all the money in the world to take to multiple mechanics. I am Savvy when it comes to fixing things but not diagnostics.

Things that have been replaced
The AC lines have been blown out a few times.
New Compressor
New Blower Motor
New Cabin Air Filter
Hi, I am having the exact same issues I have had the AC compressor and condenser replaced due to my AC stopped working, after all that my heat is still not blowing consistently through the vents inside the cabin area.
The dealer does not know they want to keep replacing things and keep getting money which is not acceptable. I’ve called corporate corporate says they have no one that has brought to their attention. Anything along these concerns I have asked them myself to document my issue, hopefully others that have the issue will call Lynn to corporate and let them know theirs as well. Maybe we can get this under control and under a recall possibly if we all work together on it . I know High I’m tired of spending money on this vehicle and was going to purchase a brand new one exact model now that I’ve had all these issues. I will definitely not be doing that.
It’s something that is closing and won’t open like a blower door
 

·
Registered
Joined
·
4 Posts
So did this fix hold up and completely resolve your issue?
I am going to try this as ours just went out AGAIN 100 miles into a 280 mile drive today. Its 39 degrees outside and we have kids in the car. I told my wife, that's it - this [email protected]#ing 2015 QX60 is going in the trash and we are getting a new car. But I am hopeful this will fix it as I've never heard of this fix but have been to dealers and mechanics enough in the last 1.5 years with the same issue.
Hi I took my filter completely out for two weeks during the summer it still did it. It 35 degrees here. I need heat
 
41 - 48 of 48 Posts
Top