Infiniti QX60 Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I need Help!

I have a 2015 QX60
I have a 2 part issue

Part 1
My ac line contentious to freeze.... Its now cold and the heat is on.... this should not be happening.

Part 2
After driving the car for about 30 min the AC or Heat will not come out of the vents. The blower sounds like a jet engine by the glove box.

This issue has been going on for about a year now and I'm over it. I have taken this to a mechanic and they kept the car for a week and "Cant Replicate The Issue" Not sure what else to do. I don't have all the money in the world to take to multiple mechanics. I am Savvy when it comes to fixing things but not diagnostics.

Things that have been replaced
The AC lines have been blown out a few times.
New Compressor
New Blower Motor
New Cabin Air Filter
 

·
Registered
Joined
·
443 Posts
Did you take it to an Infiniti dealer? If yes, call Infiniti customer service. If not, then it sounds like the mechanic(s) you took your car to are just swapping parts hoping they find the issue...they don’t have enough familiarity with the design diagnosed the actual problem.
 

·
Registered
Joined
·
2 Posts
I need Help!

I have a 2015 QX60
I have a 2 part issue

Part 1
My ac line contentious to freeze.... Its now cold and the heat is on.... this should not be happening.

Part 2
After driving the car for about 30 min the AC or Heat will not come out of the vents. The blower sounds like a jet engine by the glove box.

This issue has been going on for about a year now and I'm over it. I have taken this to a mechanic and they kept the car for a week and "Cant Replicate The Issue" Not sure what else to do. I don't have all the money in the world to take to multiple mechanics. I am Savvy when it comes to fixing things but not diagnostics.

Things that have been replaced
The AC lines have been blown out a few times.
New Compressor
New Blower Motor
New Cabin Air Filter

My QX60 - 2015 has had the same exact issue. I've had the everything you mentioned changed except the AC lines. So far the Infinity dealership did not find the issue - they want to replace the compressor since I had it replaced outside the dealership, but they cannot guarantee the issue to be fixed. My mechanic has had the car for the 5th time, claims he has found the issue, but I doubt it since my car has been at his shop for over a week. By this point I am done and will be trading my car in if it is not fixed. I wanted a new QX60, but if this is an issue with QX60 I will probably get something else
 

·
Registered
Joined
·
3 Posts
My QX60 - 2015 has had the same exact issue. I've had the everything you mentioned changed except the AC lines. So far the Infinity dealership did not find the issue - they want to replace the compressor since I had it replaced outside the dealership, but they cannot guarantee the issue to be fixed. My mechanic has had the car for the 5th time, claims he has found the issue, but I doubt it since my car has been at his shop for over a week. By this point I am done and will be trading my car in if it is not fixed. I wanted a new QX60, but if this is an issue with QX60 I will probably get something else
Did you ever get this sorted out? I have a 2015 QX60 and I'm having the same issue. Same parts changed on mine and left the car at mechanic for weeks, can't find the problem. It is freezing in the car if I drive it for more than 15 minutes. Completely unnacceptable.
 

·
Registered
2017 QX Infiniti
Joined
·
3 Posts
2017 QX purchased in June- I'm having the same issue with my heat. After 15 minutes, my heat stops putting out heat, yet its blowing as if it is...I thought it was user error since I initially could not figure out the difference between " Auto" and climate control...but after about 3 weeks..I know its not me.

At any rate- Im at the Infiniti Dealer now. This is my first time bringing it in for this. I'm waiting now- but the tech guy just told me this has happened before and a hard reset has fixed other QX 60s with this issue. So..Im just waiting to see what this does. I'll be sure to provide updates to see what else they say
 

·
Registered
Joined
·
3 Posts
Please let me know if this fixes it. It is still happening to mine. Mechanic had it for 10 days and couldn't reproduce it. I get it back and within days it starts happening. You have to drive it for 15 minutes and blower is going but no air. I put a camera in the vents and when I change from upper to lower I see the flaps moving so I know those are OK. And it also works perfectly the first 15 min so something is happening after it is driven for a bit.

My mechanic updated all of the software and reset everything as he said the software was out of date and the manufacturer recommended it to be upgraded. Still no fix.
 

·
Registered
Joined
·
2 Posts
Please let me know if this fixes it. It is still happening to mine. Mechanic had it for 10 days and couldn't reproduce it. I get it back and within days it starts happening. You have to drive it for 15 minutes and blower is going but no air. I put a camera in the vents and when I change from upper to lower I see the flaps moving so I know those are OK. And it also works perfectly the first 15 min so something is happening after it is driven for a bit.

My mechanic updated all of the software and reset everything as he said the software was out of date and the manufacturer recommended it to be upgraded. Still no fix.

my mechanic told me he had to reprogram the compressor- not sure what that means

he also had to get a machine from infinity in order to do this since he was not an infinity dealership mechanic
 

·
Registered
Joined
·
3 Posts
my mechanic told me he had to reprogram the compressor- not sure what that means

he also had to get a machine from infinity in order to do this since he was not an infinity dealership mechanic

Would you mind providing me with your mechanics number so my mechanic can chat with him? If you could email it to [email protected] i would really appreciate it


Thanks in advance.
 

·
Registered
2017 QX Infiniti
Joined
·
3 Posts
2017 QX purchased in June- I'm having the same issue with my heat. After 15 minutes, my heat stops putting out heat, yet its blowing as if it is...I thought it was user error since I initially could not figure out the difference between " Auto" and climate control...but after about 3 weeks..I know its not me.

At any rate- Im at the Infiniti Dealer now. This is my first time bringing it in for this. I'm waiting now- but the tech guy just told me this has happened before and a hard reset has fixed other QX 60s with this issue. So..Im just waiting to see what this does. I'll be sure to provide updates to see what else they say

UPDATE: no, this did not work! Heat blows fine for 15 mins and quits! I do find it resets every time you turn the car off and back on- but I'm not living like this! I have another appointment on Monday where they want me to leave it there for a few days. I really want to contact Infiniti Motor Co...this has to be a faulty build.
 

·
Registered
2017 QX Infiniti
Joined
·
3 Posts
my mechanic told me he had to reprogram the compressor- not sure what that means

he also had to get a machine from infinity in order to do this since he was not an infinity dealership mechanic
So..did re programming the compressor work?
 

·
Registered
Joined
·
1 Posts
If anyone has any updated input I would love to hear. Our 2015 QX60 has the SAME PROBLEM and it is absolutely driving us mad! Every single time we take it in, the dealer cannot reproduce the symptom...then BAM it starts happening as soon as we drive it the next day. Ours is the same as a member above: it works fine then barely a breeze and the blower below the glovebox gets very loud.
 

·
Registered
Joined
·
1 Posts
If anyone has any updated input I would love to hear. Our 2015 QX60 has the SAME PROBLEM and it is absolutely driving us mad! Every single time we take it in, the dealer cannot reproduce the symptom...then BAM it starts happening as soon as we drive it the next day. Ours is the same as a member above: it works fine then barely a breeze and the blower below the glovebox gets very loud.
I recently purchased a 2015 QX60 and same thing fine at first then minimal air flow, also thinking something is up with heated steering wheel because it is intermittent as well and it sees to happen in step with the air issue. does anyone also have an issue with heated steering wheel or is it just me? a lot of the same fuses and relays are used for both so could be a link?
 
1 - 12 of 12 Posts
Top