Infiniti QX60 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
What could this be? Its driving me mad!


-Almost seems like its generally around the rear passenger second row seat area

-only happens at moderate mph (40-60) but doesnt do it all of the time.

Things checked

-license plate/holder
-roof rack screws/covers
-took everything out of the car including glove box, jack in the back etc
-mudflaps and pins look ok
-weather stripping not loose
-all pins under the wheel arches look ok
 

·
Registered
Joined
·
10 Posts
Your video link is not working, hart to tell without it. For me it was the little wind deflector flap in front of the right rear wheel, is that what you refer to as mudflaps?
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Ok i solved it. It was the roof rack. If you take a look at it there is a piece of thin foam under the joint from the bar to the angle that attaches on the car. So if you tighten the torques screw down with no foam/too littlefoam-it is not actually tight! It is surprising this make such a big noise. Anyway i took them off to fix and havent heard the rattle.

Another thing i noticed was that the rattle is worse going downhill and doesn't happen going up hill so if you think about it- its probably the air flow acting on the roof racks.

Anyway something to check if you are experiencing this.
Azure Door Fixture Bumper Vehicle door
 

·
Registered
Joined
·
689 Posts
Once in a great while I get a strange loud fast-vibration from the roof area (factory installed roof rack and crossbar) during strong cross winds. It's happened maybe 10 times in the last 9 years, but still bothersome. I'll check out the connections you've referenced. Thanks.
 
1 - 4 of 4 Posts
Top