Infiniti QX60 Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Purchased new and had really bad transmission shudder at low speeds which seems to be fixed after the dealer replaced the valve body on the transmission.

The power band is still pretty crappy though. From a stop if it was a geared normal transmission it would feels like going from 1st to 3rd. A massive loss of power off the line but the power is there at higher speeds. I know CVT will take some getting used to but this one seems off to me. Anyone else experiencing a loss of power at lower RPM's.
 

·
Registered
Joined
·
17 Posts
I own a 2014 and had same transmission issue. they replaced the entire transmission for me. I haven't really noticed any power loss but the entire drive/feel of the car is totally different then before. Not sure i like it as much as the original drive. I noticed that the fuel economy is no where near the stated 26 mpg highway (we used to get near 25), the rolling start doesn't exist like it did before and the engine has a higher rpm at cruising speeds on the highway.
 

·
Registered
Joined
·
295 Posts
Hopefully these issues don't persist since it can eventually lead to following under the criteria that allows you to use lemon laws. Just make sure to check with your local lemon laws to know exactly at what point it can come in .
 

·
Premium Member
Joined
·
539 Posts
Try it in sport mode?
 

·
Registered
Joined
·
295 Posts
Try it in sport mode?
That's a good idea and might help to find out or weed out the situations where it could come up since it helps to give the service people some criteria on how to diagnose the issue since they might not know under what conditions it happens or doesn't.
 
1 - 5 of 5 Posts
Top