Infiniti QX60 Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
MY2014 QX60

Purchased a Tekonsha 118670 4-pin trailer wiring harness.

There are a few videos showing the installation step-by-step and I followed them with diligence. However, I'm not getting any power at the 4-pin connector despite getting power to the relay jumper harness. I can even feel the heat generated from 2 of the 3 relays on the jumper harness. I've checked all fuses and relays and everything seems to be in working order. Would any of you guys happen to have any pointers?

-Q
 

·
Registered
Joined
·
18 Posts
I just did this this weekend on a 2017. I'm sure you have done this but make sure the relays under the hood are clicked into place. Another thought is to check voltage at the plug where your 4 pin plugs in under the bumper in back.
 

·
Registered
Joined
·
10 Posts
MY2014 QX60

Purchased a Tekonsha 118670 4-pin trailer wiring harness.

There are a few videos showing the installation step-by-step and I followed them with diligence. However, I'm not getting any power at the 4-pin connector despite getting power to the relay jumper harness. I can even feel the heat generated from 2 of the 3 relays on the jumper harness. I've checked all fuses and relays and everything seems to be in working order. Would any of you guys happen to have any pointers?

-Q
have you have any luck with this? ive installed this on my 2013 jx and only getting parking light. my signals and brakes do not work.
 

·
Registered
Joined
·
74 Posts
Why not install the correct factory wiring harness? Its less than $100 and makes this all directly plug-and-play?

Its not 4 pin but 7 and works great.
 
1 - 4 of 4 Posts
Top