Infiniti QX60 Forum banner

41 - 48 of 48 Posts

·
Registered
Joined
·
74 Posts
Discussion Starter #41
**UPDATE**

So the car passed the German safety inspection on Friday of last week and I got license plates for it Saturday morning and Saturday night it get placed "in service" when six of us decided to go to dinner.

Sunday afternoon, when it was a comfortable 37° F outside I did some work on the vehicle.

The service shop that did the headlight washing system retrofit forgot to plug back in the front camera, so I did that. Took all of five minutes.

The drivers' side Bose speaker on the dash took on some water in the accident and it was toast, so I replaced it with one out of a 370Z. The FSM says you need to take out the windshield to do this -- but this is abjectly incorrect, it CAN be done with the windshield in the car, just takes a little bit of "finagling".

I also replaced the gauge cluster with a used example from a Canadian vehicle and it was completely "plug & play" with nothing not working thereafter.

The winter tires I put on the car, I didn't think TPMS sensors were required and it could be done simply by the rotation of the wheel, but the QX60 still uses TPMS sensors, so the car is currently throwing a TPMS error, but I've ordered new 433Mhz TPMS sensors and I'll have them put in once they arrive.

When I put winter wheels on, unfortunately one of the nuts was cross-threaded and it destroyed the nut and bolt when taking it off, thus on the passenger rear side -- there are only four nuts on there. I've ordered the new parts but they have yet to arrive. Once they get here, I'll do a full brake job on the thing + brake fluid.

I've ordered a hacked Navigation system out of Russia which arrives this week, so I'll be swapping that out to get European maps on the vehicle as well as get it to speak German.

So yeah, that is where I am at with it as it stands. Paint still needs attention.
 

·
Registered
Joined
·
134 Posts
Great story to read. It’s amazing the amount of damage that tree branch and resulting water leakage caused. How did the paint blending come out at the roof line?
 

·
Registered
Joined
·
134 Posts
Great story to read. It’s amazing the amount of damage that tree branch and resulting water leakage caused. How did the paint blending come out at the roof line?
 

·
Registered
Joined
·
74 Posts
Discussion Starter #44 (Edited)
Sorry for the delay in getting back to you.

All the painting I did the vehicle is under the roof railing or under the rear hatch, so I did exactly no blending. I did order color-matched paint and OEM clear so its exceptionally hard to see what I've done unless you're specifically looking for it.

I swapped out the gauge cluster and like other Nissan vehicles, it was a direct swap no coding necessary.

Hacked Russian navigation system works great and without issue although my new Huiway P20 Pro doesn't play so well with it -- then again it has a hard time with my BMW so I think the fault is with the phone and not the vehicle.

When the weather improves things to do:

- PDR on the vehicle;
- Few dents have broken through the paint so I'll need to have this done as well;
- Trans oil flush
- Rear-diff oil flush
- Spark plugs
- Install new 3000k HID fogs
- Swap out drivers side window switch on drivers door (glass is jammed in the current one so I cannot control front pass. window from driver's switch);
- Full detail

I've done new brake pads and rotors and had the windshield re-sealed (had a slight leak).

Other than that, we've done about 4,000 miles on the car since it arrived and haven't had any issues.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #45
Hey all,

So I thought I'd update everyone on what I've accomplished thus far:

1) Trans fluid flush;
2) Rear-diff flush;
3) Another oil change;
4) Brake fluid flush;
5) New pads and rotors;
6) Slowly purging the power steering fluid (I'm taking it out the top and refilling with a urine catheter syringe as I am exceptionally lazy);
7) 3000k HID fogs;

Because you have to take of the intake manifold to get to the rear spark plugs, I decided I'll do those when the manual calls for them (being 105,000 miles or 170,000 kilometers).

Other than that -- the car runs so much better with premium than normal gas -- the difference is shocking. I'll stick with premium fuel from here on out.
 

·
Registered
Joined
·
250 Posts
I am exceptionally lazy

No, just no. You don't come here and do the most amount of work I've ever seen someone do on a car, and go to lengths almost nobody ever has, and then say you are lazy. Because that means I am comatose and some of my friends are dead, by comparison.
 

·
Registered
Joined
·
74 Posts
Discussion Starter #47
No, just no. You don't come here and do the most amount of work I've ever seen someone do on a car, and go to lengths almost nobody ever has, and then say you are lazy. Because that means I am comatose and some of my friends are dead, by comparison.
haha, well thank you. Perhaps let me rephrase:

I am exceptionally cheap and I didn't feel like paying someone to flush the power steering fluid. To get the high and low pressure hoses off the rack I'd have to craw around in the dirt under the car and I didn't feel like doing that either.

So I had my wife snag a pee catheter syringe from work, I drilled a small hole in the "filter" housing of the power steering tank and suck 120 ml to 180 ml of fluid out at a time, refill with fresh fluid and then drive it for a week and repeat the process.

It takes a couple months of doing this every weekend but I get the entire power steering system flushed for like $20 and I don't have to crawl around in the dirt under the car.

So I guess I work like this:

cheap > lazy > crawling around in the dirt under the car >:D
 

·
Registered
Joined
·
74 Posts
Discussion Starter #48
So gents,

As a means of keeping everyone in the loop -- the car developed a really horrid squeak/chirp/peep/squeal from the back of the car at low speeds when going over bumpy surfaces. It was so loud it was driving me nuts I actually had a hard time getting into the vehicle anymore as our driveway is made of these 150 year old cobble stones which really triggered it.

Anyways after a night at the beer garden I had had far too much to drink, my wife was kind enough to drive home and I sat in the third row determined to find the source of this sound. I thought it was the rear clips of the headliner or perhaps the rear dome light ... it wasn't -- it was actually the rear hatch latch. If you recall from page two of this thread -- I took the rear hatch off the car to take the top off -- and in doing so somehow the rear latch dried out.

I put a generous amount of silicon WD-40 all over the latch -- I then pulled the emergency open cover off the tail gate and put more WD-40 in there -- now its completely silent again.

Vehicle has 115,000 kilometers now (71,000 miles) and apart from a knocking sound from the front passenger side of the vehicle (there is a JX TSB on this issue) its working great. I recently got 34 MPG highway with the thing (I was going essentially 55 and I quite literally got a dirty look from the driver of a bus full on nuns -- but I digress) and still the best and worst part of the car are the same - the transmission.

I love the CVT because it keeps gas consumption low (normal tank of gas here in Germany with premium is about $110 USD) but I hate it because it just kills the ability of this thing to tow.

I'm seriously looking as a 2010-2012 Ranger Rover HSE or a 2010+ Nissan Armada Platinum (wrecked from the salvage yard of course) as a toy. I'd love to get myself a boat (also to be a salvage yard purchase) to schlep around.

Anyways, just wanted to keep everyone updated.

Oh I updated the entire interior to LEDs.

Best,

Gat
 
41 - 48 of 48 Posts
Top