Headrest monitor not working - Infiniti QX60 Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 6 (permalink) Old 10-04-2019, 10:36 AM Thread Starter
Junior Member
 
Join Date: Oct 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Question Headrest monitor not working

Hello -

I have a 2017 with the monitors in the headrests. The driver's side monitor started flickering as another member mentioned, and then went completely out. Does anybody have any suggestions on troubleshooting? I really don't want to take this to the dealer to get fixed as I am sure they will tell me it just needs replaced. Seems awful "young" to be having a monitor go bad. Thanks in advance for any pointers of where the cabling is located, what to look for, etc.

Russ
[email protected] is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 10-04-2019, 06:17 PM Thread Starter
Junior Member
 
Join Date: Oct 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Edit: I did some more troubleshooting and looks like the monitor is back working again, but will get “snow” for a few seconds, followed by a blue screen a second or two and then back to the video. It did this roughly three or four times over about 10 minutes. The other monitor does not flicker at all.

Quote:
Originally Posted by [email protected] View Post
Hello -

I have a 2017 with the monitors in the headrests. The driver's side monitor started flickering as another member mentioned, and then went completely out. Does anybody have any suggestions on troubleshooting? I really don't want to take this to the dealer to get fixed as I am sure they will tell me it just needs replaced. Seems awful "young" to be having a monitor go bad. Thanks in advance for any pointers of where the cabling is located, what to look for, etc.

Russ
[email protected] is offline  
post #3 of 6 (permalink) Old 10-04-2019, 07:54 PM
Senior Member
 
Rooster's Avatar
 
Join Date: Mar 2014
Location: Fredericksburg, VA
Posts: 305
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 55 Post(s)
Isn’t it still covered under the 4 bumper to bumper warranty?
Rooster is offline  
 
post #4 of 6 (permalink) Old 10-09-2019, 10:46 AM
Junior Member
 
Join Date: May 2018
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
My left monitor used to flicker once in a while. My workaround was to pull the headrest one click up/down then the flickering goes away. I took it to the dealer and they were able to replicate the issue. They said they tighten up all the connections and harness with extra tape etc. I haven't had any flickering issue since then. However, the right monitor flickered once very recently then i used my workaround technique to fix it. Hope this helps!

P.S, the dealer said it was covered under the warranty.
omuamua is offline  
post #5 of 6 (permalink) Old 10-09-2019, 06:54 PM Thread Starter
Junior Member
 
Join Date: Oct 2019
Posts: 3
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thank you for the advice! I tried that, but it didn’t seem to make a difference.

I am not sure if it is still under warranty as we bought it used. I will have to look into that. It would be awesome if it was covered! Or maybe they would do a “good will” repair of all they are doing is tightening up the connections...





Quote:
Originally Posted by yshaik View Post
My left monitor used to flicker once in a while. My workaround was to pull the headrest one click up/down then the flickering goes away. I took it to the dealer and they were able to replicate the issue. They said they tighten up all the connections and harness with extra tape etc. I haven't had any flickering issue since then. However, the right monitor flickered once very recently then i used my workaround technique to fix it. Hope this helps!

P.S, the dealer said it was covered under the warranty.
[email protected] is offline  
post #6 of 6 (permalink) Old 10-10-2019, 10:14 AM
Junior Member
 
Join Date: May 2018
Posts: 12
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
I too have the 2017 QX60.

As long as you meet "4 yr/60,000 mi basic, 6 yr/70,000 mi power train" it should be covered under the warranty. Please do share your experience how you managed to fix the issue. Good luck!
omuamua is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome