LED turn signals blink very quickly - Infiniti QX60 Forum
User Tag List

 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 06-24-2019, 11:21 AM Thread Starter
Senior Member
 
Join Date: Feb 2019
Location: Ohio
Posts: 146
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
LED turn signals blink very quickly

Hey Guys! I have a 2015 QX60 and have swapped virtually all bulbs inside and out to LEDs (except headlights and brake lights). So far, ALL the swaps are good ones and look MUCH better. I decided to finish off everything by swapping out the turn signal bulbs front and back to LED. Not because any of them weren't functioning, just for the sake of knowing I did all that I could. But didn't consider the difference of halogen vs. LED ahead of time and now the stupid turn signals blink real fast, like they would if one bulb was burned out (I checked, and no all LED bulbs do work). Oddly the hazards blink at a normal, slower pace. I am sure it is because of the lower resistance from the LEDs. But somewhat surprised it doesn't affect the hazards similarly. I am not real interested in splicing the wiring to add a resistor to the circuit to resolve. Probably should have thought about this ahead of time and purchased more expensive bulbs with built in resistors to prevent this altogether. But, now they're all in and I really don't feel like taking them all back out, returning to amazon, and buying new to put back in. Anyway, I guess my question is: is there a way to set the frequency of turn signals somehow that I am missing? or am I probably going to have to just get used to the rapid blinking?


on the plus side, the LEDs that I put in there were the correct bulbs on the first try purchasing LOL and they are SUPER bright and look great
jonesy84 is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 06-24-2019, 09:24 PM
Senior Member
 
Join Date: Apr 2017
Location: Miami, Florida
Posts: 250
Mentioned: 0 Post(s)
Tagged: 1 Thread(s)
Quoted: 55 Post(s)
Garage
I'm not aware of a user-controllable setting for that, and I would doubt there is one. With a OBDII programmer and the right codes it might be possible. On my Mustang, I have the same situation because I'm using switchbacks. I have a programmable option through the OBDII port to enable/disable hyperflash. Disabling it makes the turn signals flash normally even with LEDs and no resistors. But no idea if you can do that on the QX60.

2014 Infiniti QX60 AWD (every available feature except tow package)
2017 Ford Mustang GT Convertible
2014 Ford Escape Titanium
2014 Toyota Camry SE
NemoEsq is offline  
post #3 of 3 (permalink) Old 06-25-2019, 10:45 AM Thread Starter
Senior Member
 
Join Date: Feb 2019
Location: Ohio
Posts: 146
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
Quote:
Originally Posted by NemoEsq View Post
I'm not aware of a user-controllable setting for that, and I would doubt there is one. With a OBDII programmer and the right codes it might be possible. On my Mustang, I have the same situation because I'm using switchbacks. I have a programmable option through the OBDII port to enable/disable hyperflash. Disabling it makes the turn signals flash normally even with LEDs and no resistors. But no idea if you can do that on the QX60.
what's an OBDII programmer? Would the dealership have something that could disable hyperflash? or better yet, would they if I asked them to do you think? or would they try to tell me that's something they can't do?
jonesy84 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome