Anti-Freeze / Coolant Smell When Warm?! - Infiniti QX60 Forum
User Tag List

 1Likes
  • 1 Post By golftango
 
LinkBack Thread Tools
post #1 of 5 (permalink) Old 04-20-2014, 12:34 AM Thread Starter
Junior Member
 
Join Date: Mar 2014
Posts: 8
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Exclamation Anti-Freeze / Coolant Smell When Warm?!

Hey guys,

I have a 2013 "QX60" (JX35) and whenever the truck warms up it smell sof coolant / antifreeze outside the car. The hotter the truck gets, the more it smells... I took it into the dealership and they agreed they could smell it, but they said they couldn't find a leak?

Super embarrassing.... This is my first and likely only Infiniti purchase, given this + the CVT transmission judder....


Anyone found the cause of the burning coolant smell?
amorak is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 05-01-2014, 09:25 PM
Senior Member
 
Join Date: Jan 2014
Location: Everett, WA
Posts: 199
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 36 Post(s)
How many miles do you have on yours? When they get shipped, Infiniti puts a protectant on the engine so that salt does not corrode anything. It will smell like this for about 500 miles. Other than that, I am not sure what it could be without having it here.
mattreading22 is offline  
post #3 of 5 (permalink) Old 06-23-2017, 12:29 PM
Junior Member
 
Join Date: Jun 2017
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Yes I have the same issue it uses coolant and I get a smell when it warms up .Dealer said they could not find it and tried to tell me I was looking at the wrong bottle .I've Ben a certified auto tech for over 34 years I know what I'm looking at and smell .I just made a appointment for Tuesday for that and other issues as far as rear bearing noise sun visors and recalls will repost after my visit

Last edited by Wmorris2011; 06-23-2017 at 12:32 PM.
Wmorris2011 is offline  
 
post #4 of 5 (permalink) Old 06-14-2019, 04:28 PM
Senior Member
 
golftango's Avatar
 
Join Date: Feb 2019
Location: CT
Posts: 102
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Having this same issue with my 2015 with 20K. Dealer says that Infiniti / Nissan are aware of the issue, but have no resolution? Coolant level is fine, so is temp, so I guess i'm not too concerned.
jonesy84 likes this.

2015 QX60 - Majestic White & Wheat
Premium & Premium Plus

2017 Honda Accord Sport SE
San Marino Red & Black - 6MT
golftango is offline  
post #5 of 5 (permalink) Old 06-21-2019, 04:56 PM
Senior Member
 
Join Date: Feb 2019
Location: Ohio
Posts: 157
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 37 Post(s)
Quote:
Originally Posted by golftango View Post
Having this same issue with my 2015 with 20K. Dealer says that Infiniti / Nissan are aware of the issue, but have no resolution? Coolant level is fine, so is temp, so I guess i'm not too concerned.


same exact situation with me. Also 2015, only a few more miles than yours. I notice a distinct smell of warm coolant very plainly when I walk past the front of my car, especially now that warmer weather is (finally) here. I am acutely aware of the smell because we just had a water pump go out on our minivan so I have smelled A LOT of coolant lately LOL but same for me, no leaks, no temp issues, levels in reservoir seem constant, so nothing I am overly worried about. I think it may be a quirk of the car, though not sure why
jonesy84 is offline  
Reply

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome